Swirl German UTF-characters problem


I've read through many posts relating to encoding issues, but non of them helped or was applicable to my case. I am doing Swirl exercises which involve German characters including ä, ü, ö and ß. However, these are displayed both in R and in RStudio as, for example <U+00DF>, (ß). This becomes problematic when these characters feature in Swirl's multiple choice questions, because, if the correct answer contains such characters, the problematic characters are submitted as an answer and not accepted by the Swirl lesson. In this case, it is also not possible to skip the question.

I've tried to run 'defaults write org.R-project.R force.LANG de_DE.UTF-8' in the Terminal, but this didn't solve the issue. I am using a mac running macOS Mojave and the latest verisions of both R and R Studio, UTF-8 is set as default encoding system, the computer was bought in Belgium.

Kind regards!

Hi @flvdrhae! Welcome!

Sounds like a frustrating situation! I know you said you’re using “the latest versions” of R and RStudio, but can you please clarify your system info, and provide your sessionInfo() output as a starting point? With both the current main release and the preview release of RStudio in active use, it’s difficult to know what people mean by “the latest version”.

Here’s a system info template you can use...

System Information:

  • RStudio Edition: (Desktop or Server)
  • RStudio Version:
  • OS Version:
  • R Version:


Depending on your issue, the following may be useful
If a section isn't relevant or you can't collect it just delete that section below

Also, it sounds like you saw this thread already, but the ultimate fix there was to update to a Preview release version where the Mojave bug was dealt with — have you tried that? Did your problem persist?