Terminal Creation Failure - The specified module could not be found

Hello. I am running RStudio 2022.07.2 Built 576 "Spotted Wakerobin" Release and I am suddenly not able to use Terminal in RStudio. When I start up RStudio and click on the Terminal tab, there's a blinking cursor and no option to write any text. When I close and try to open a new terminal I get a box popping up that says "Terminal Creation Failure - The specified module could not be found".

I was using a much older 2021 version of RStudio so I tried upgrading to a newer 2022 version but the error persists. I am running 64-bit R-4.1.2.

I saw that a similar issue was created in 2021 without a resolution it appeared.

Here's my Terminal Diagnostics if that helps:

The terminal was just working for me yesterday. The only change I can think of is I downloaded and installed the gargle package and experimented with some gargle options. I am pretty baffled by this one.

Just figured out the answer to my own question and going to post it here for anyone to see!

I followed the Windows provided workflow at The error “The specified module could not be found” - Microsoft Community, in particular #3 - "Damaged Windows Registry Files", and rebooted my PC, and that solved my issue! Hope this helps others who run into the same problem!