There‘s no package called ‚dplyr‘.

Does anybody have a solution for this problem?
I use RStudio-2023.03.1-446 on a MacBooPro (2015), MacOS Monterey Version 12.6.6 and need this package for my data preparation, concretely to inner, left or outer join two tables with a different number of lines. However, the package do not exist on this Version of RStudio and a later Version RStudio-2023.06.0-421 I am not able to download.

Best regards

Have you installed the dplyr package? You can do that in RStudio by selecting the menu Tools -> Install Packages. A dialog will appear with three boxes. The middle box is labeled Packages. Type dplyr there and click Install.

Maybe you misunderstand the mechanism - or you have not made the problem clear to us.
RStudio does not include packages "out of the box". You have to install them.
You don't have to download - you just use the command mentioned by @FJCC

Rstudio and R, are quite different. the former being an IDE to facilitate programming in the latter. I will assume you are using the latest R version which is 4.3
on the CRAN dplyr page, the macosx x86 link shows a downloadable binary at
this link :
which is what I would try in your shoes.
if it doesnt work, you could install Xcode for macosx and try compiling from source, but it may present further hurdles.

Well, I thought that I can presuppose the step, that I already tried to install the package, because I provided in my head-line the answer of RStudio, which was that there do not exist any ‚dplyr’ package in the mentioned version of RStudio.

Perhaps you could show us a screenshot/text copy of how you tried to install dplyr and what the error message was.
I maybe tell us the version of R itself

The version I use, RStudio-2023.03.1-446, I already mentioned in the origin message. Sending you a screenshot/photo of the RScript and Console after my first try of installing the package is not possible anymore, because someone else than me gained access to my project via means of distance communication and cleaned the Console and the Environment.

I now tried to install ‚dplyr‘ again and got a different answer. Now, the package was ob viously downloaded, see photo.

However, now, I can not use it, because the three previously prepared data sets are not in the environment anymore and only stored in the RScript. So, my question is how can someone get access to my Rproject and clean without my consent the Console and Environment and how can I get especially the three elaborated prepared data sets back)?

R and RStudio are very different. You were asked to report the installed version of R. Your response was to repeat the version of RStudio from your original post. Your screenshot happens to include the top of the Console pane, which shows the version of R as 4.1.2. This is a couple of years old but should work. The latest version is R 4.3.1.

It is unlikely that someone accessed your computer remotely and deleted the Console and Environment. The Console record is not saved when you exit RStudio. This is why you should be saving all your code in an R Script, R Notebook, or Quarto document.

If you want to keep the contents of the Environment, go to the Tools menu, select Global Options ..., check the box under Workspace for "Restore .RData into Workspace on startup", then select "Always" or "Ask" for "Save Workspace to .RData on exit".

Yes, reporting the RStudio Version was a wrong, but less important answer, as the Version of R obviously do not explain why the previous tries did not lead to the wish-ed outcome.

I did not exit RStudio and the box under “tools”, “global options”, “workspace” was already pressed for “Restore.RData into workspace at startup” and configured for “ask” “save workspace to RData on exist”, so I still wonder where the three data sets in the environment have gone and how I get them back.

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.