Tidyverse install error: there is no package called ‘Rcpp’

I've been having trouble having upgraded to tidyverse 1.2.1 - I get this:

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘Rcpp’
In addition: Warning message:
package ‘tidyverse’ was built under R version 3.4.3

I don't think I ever upgraded to 1.2 so can't comment on whether that was also a problem for me.

Should I go back to 1.2.1?

Typically if you get an error message to the effect of there is no package called **insert package name here**, a good first troubleshooting step is to try installing that package manually.

So, in this case, try installing Rcpp:

1 Like

Thanks - I had tried yesterday but it hadn't worked. Have just tried again and it worked!. Then I had to install lazyeval. I don't really understand why they weren't there. I definitely had Rcpp before.

Still I now have it up and running so hopefully no more problems. Panic over.

1 Like

2 posts were split to a new topic: tidyverse package install and "there is no package called ‘Rcpp’" error, anyway to prevent this error