tidyverse installation problems with macbook

I'm trying to install and call the tidyverse package on RStudio (not in Conda) on a 2017 MacBook (updated).

System Information:

  • RStudio Version: 1.3.959
  • OS Version: macOS Catalina 10.15.5

Here's what I see:

#REPREX

install.packages("tidyverse")

What I get:

trying URL 'https://cran.rstudio.com/bin/macosx/contrib/4.0/tidyverse_1.3.0.tgz'

Content type 'application/x-gzip' length 432850 bytes (422 KB)

==================================================

downloaded 422 KB

The downloaded binary packages are in

/var/folders/mq/bzz01vj95w358hxs2tcc3wbr0000gn/T//Rtmpi53aau/downloaded_packages

library(tidyverse)

error I get:

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):

there is no package called ‘fs’

Try installing fs on its own and retry installing tidyverse.

Glad it worked !

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Thanks! That did work. I had to select "no" when installing fs as there was the following code that came up but regardless this worked well, thank you!

install.packages("fs")

There is a binary version available but the source version is later:
binary source needs_compilation
fs 1.4.1 1.4.2 TRUE

Do you want to install from sources the package which needs compilation? (Yes/no/cancel)

1 Like