Tidyverse not loading because of issue with dbplyr

Hi,

I am getting this error:

> library(tidyverse)
Error in completeSubclasses(classDef2, class1, obj, where) : 
  trying to get slot "subclasses" from an object of a basic class ("NULL") with no slots
Error: package or namespace load failed for ‘tidyverse’:
 .onLoad failed in loadNamespace() for 'dbplyr', details:
  call: setClass(cl, contains = c(prevClass, "VIRTUAL"), where = where)
  error: error in contained classes ("character") for class “ident”; class definition removed from ‘dbplyr’

I have tried to update 'dbplyr' as suggested here; I have also tried to reload it manually, or to load 'Matrix' first as suggested here.

Session info:

R version 4.2.0 (2022-04-22)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Mojave 10.14.6

Matrix products: default
BLAS:   /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/4.2/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] parallel  stats     graphics  grDevices utils     datasets  methods  
[8] base     

other attached packages:
[1] flextable_0.7.0      brms_2.17.0          Rcpp_1.0.8.3        
[4] rethinking_2.21      cmdstanr_0.5.2       rstan_2.21.5        
[7] ggplot2_3.3.6        StanHeaders_2.21.0-7

loaded via a namespace (and not attached):
  [1] colorspace_2.0-3     ellipsis_0.3.2       ggridges_0.5.3      
  [4] rprojroot_2.0.3      markdown_1.1         base64enc_0.1-3     
  [7] fs_1.5.2             rstudioapi_0.13      farver_2.1.0        
 [10] remotes_2.4.2        DT_0.23              fansi_1.0.3         
 [13] mvtnorm_1.1-3        xml2_1.3.3           bridgesampling_1.1-2
 [16] codetools_0.2-18     cachem_1.0.6         knitr_1.39          
 [19] shinythemes_1.2.0    pkgload_1.2.4        bayesplot_1.9.0     
 [22] jsonlite_1.8.0       broom_0.8.0          shiny_1.7.1         
 [25] compiler_4.2.0       backports_1.4.1      assertthat_0.2.1    
 [28] Matrix_1.4-1         fastmap_1.1.0        cli_3.3.0           
 [31] later_1.3.0          htmltools_0.5.2      prettyunits_1.1.1   
 [34] tools_4.2.0          igraph_1.3.1         coda_0.19-4         
 [37] gtable_0.3.0         glue_1.6.2           reshape2_1.4.4      
 [40] dplyr_1.0.9          posterior_1.2.1      vctrs_0.4.1         
 [43] nlme_3.1-157         crosstalk_1.2.0      tensorA_0.36.2      
 [46] xfun_0.31            stringr_1.4.0        ps_1.7.0            
 [49] brio_1.1.3           testthat_3.1.4       mime_0.12           
 [52] miniUI_0.1.1.1       lifecycle_1.0.1      gtools_3.9.2        
 [55] devtools_2.4.3       MASS_7.3-56          zoo_1.8-10          
 [58] scales_1.2.0         colourpicker_1.1.1   promises_1.2.0.1    
 [61] Brobdingnag_1.2-7    inline_0.3.19        shinystan_2.6.0     
 [64] curl_4.3.2           memoise_2.0.1        gridExtra_2.3       
 [67] gdtools_0.2.4        loo_2.5.1            stringi_1.7.6       
 [70] dygraphs_1.1.1.6     desc_1.4.1           checkmate_2.1.0     
 [73] zip_2.2.0            pkgbuild_1.3.1       shape_1.4.6         
 [76] systemfonts_1.0.4    rlang_1.0.2          pkgconfig_2.0.3     
 [79] matrixStats_0.62.0   distributional_0.3.0 evaluate_0.15       
 [82] lattice_0.20-45      purrr_0.3.4          rstantools_2.2.0    
 [85] htmlwidgets_1.5.4    processx_3.5.3       tidyselect_1.1.2    
 [88] plyr_1.8.7           magrittr_2.0.3       R6_2.5.1            
 [91] generics_0.1.2       DBI_1.1.2            pillar_1.7.0        
 [94] withr_2.5.0          xts_0.12.1           abind_1.4-5         
 [97] tibble_3.1.7         crayon_1.5.1         uuid_1.1-0          
[100] utf8_1.2.2           rmarkdown_2.14       officer_0.4.2       
[103] usethis_2.1.5        grid_4.2.0           data.table_1.14.2   
[106] callr_3.7.0          threejs_0.3.3        digest_0.6.29       
[109] xtable_1.8-4         tidyr_1.2.0          httpuv_1.6.5        
[112] RcppParallel_5.1.5   stats4_4.2.0         munsell_0.5.0       
[115] sessioninfo_1.2.2    shinyjs_2.1.0

Hi Emy,

I had the same issue. It seems to have been caused by a bug in the Brobdingnag package which hasn't been updated on CRAN yet (as described here). When I installed the development version it worked fine:

devtools::install_github("RobinHankin/Brobdingnag")

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.