Tidyverse Update Problem


#1

I have just updated tidyverse via RStudio.

When I try to launch it I get the following error message:

library(tidyverse)
Error : .onAttach failed in attachNamespace() for ‘tidyverse’, details:
call: NULL
error: Function getThemeInfo not found in RStudio
Error: package or namespace load failed for ‘tidyverse’

I think this is due to the familiar binary problem:
There is a binary version available but the source version is later:
binary source needs_compilation
tidyverse 1.1.1 1.2.0 FALSE

I have uninstalled and re-installed a few times to no avail. Is there a way around this or do I have to wait for a further update?


Tidyverse package v1.2.0 installation/loading solutions
#2

Which version did you install, 1.1.1 or 1.2.0? I did a fresh install of 1.1.1 this morning and didn’t encounter problems.


#3

I was trying to install 1.2.0, but it looks like the binary source has not been compiled yet. I didn’t think that would have disabled it though.

Anyway it looks like the packages (e.g. dplyr, etc.) are not affected, so it’s not a critical issue for me, even though it could break some scripts.


#4

What is your R/Rstudio version? Are you able to update rstudioapi? What about your OS?

I don’t have an answer, but the fact that it’s referencing an API function added in RStudio 1.1 makes me suspect that there’s an old version somewhere in the pipeline. A brief Google search shows you aren’t the only one with the problem, though, and at least one person makes it sound like everything is likely up to date.


#5

Thanks @nick, it does look like everything else works apart from the tidyverse package itself.

My system is (outside my control to update):
Win 8.1
R 3.3.3
RStudio 1.0.44


#6

Probably worth updating RStudio, the current version is 1.1.38 (and/or update the rstudioapi package). The most recent version of R is 3.4.2, as well, so it might be worth updating R too.


#7

@jim89, unfortunately I am not able to update anything as I am in a corporate environment where the upgrades are provided to us infrequently.

I’ll wait to see whether an upgrade solves it or else just remember to load the individual packages and not tidyverse.


#8

Any chance you ended up on tidyverse version 1.2.0 despite the missing binary warning? I said no to installing from source but still ended up with the newest version. And it’s apparent why that version would be looking at the editor theme:

But it’s likely a bug if it’s requiring a newer version of RStudio, as there’s plenty of people that can’t stay at the bleeding edge.


#9

@nick, 1.2.0 has installed (after uninstalling). I’ll roll back until there’s a fix. Thanks for looking into it.


#10

I’ve reported the issue on the tidyverse Github here. The fix should be straightforward, but I’m not sure how long it will be before an update hits CRAN.


#11

Thanks @nick. Installing crayon did not fix it for me.


#12

I had the same problem, and was able to solve it by loading the prior version of tidyverse, as follows:

require(devtools)
install_version(“tidyverse”, version = “1.1.1”, repos = “http://cran.us.r-project.org”)


Tidyverse package v1.2.0 installation/loading solutions
#14

I had the same problem. I used RStudio “Check for package updates” and next thing you know, tidverse was malfunctioning.

JeffR’s solution above worked for me.


#15

The issue is fixed in the development version, but it’s likely easiest to wait until you see a version newer than 1.2.0 to update instead of installing from Github.


#16

thank you, it worked for me, for now.


#17

I ran into this problem myself. It seems to be working fine now after installing the development version:

devtools::install_github(“hadley/tidyverse”)


#18

Yeah, it’s been fixed and submitted to CRAN:

Keep an eye out for 1.2.1!


#19

I solved the issue updating my RStudio server.


#20

I’m new to R ( started 1 week ago).

I had the same issue in installing tidyverse but I loaded library, ggplot2 and then installation of tidyverse worked

library(ggplot2)
install.packages(“tidyverse”)
Error in install.packages : Updating loaded packages

Restarting R session…

install.packages(“tidyverse”)
also installing the dependency ‘rlang’

There is a binary version available but the source version is later:
binary source needs_compilation
tidyverse 1.2.0 1.2.1 FALSE

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/rlang_0.1.4.zip
Content type ‘application/zip’ length 463830 bytes (452 KB)
downloaded 452 KB

package ‘rlang’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
C:\Users\ruser\AppData\Local\Temp\RtmpU5eq9W\downloaded_packages
installing the source package ‘tidyverse’

trying URL 'https://cran.rstudio.com/src/contrib/tidyverse_1.2.1.tar.gz
Content type ‘application/x-gzip’ length 61647 bytes (60 KB)
downloaded 60 KB

  • installing source package ‘tidyverse’ …
    ** package ‘tidyverse’ successfully unpacked and MD5 sums checked
    ** R
    ** inst
    ** preparing package for lazy loading
    ** help
    *** installing help indices
    *** copying figures
    ** building package indices
    ** installing vignettes
    ** testing if installed package can be loaded
    *** arch - i386
    *** arch - x64
  • DONE (tidyverse)

The downloaded source packages are in
‘C:\Users\ruser\AppData\Local\Temp\RtmpU5eq9W\downloaded_packages’

library(tidyverse)
– Attaching packages ------------------------------------------------ tidyverse 1.2.1 –
v ggplot2 2.2.1 v purrr 0.2.4
v tibble 1.3.4 v dplyr 0.7.4
v tidyr 0.7.2 v stringr 1.2.0
v readr 1.1.1 v forcats 0.2.0
– Conflicts --------------------------------------------------- tidyverse_conflicts() –
x dplyr::filter() masks stats::filter()
x dplyr::lag() masks stats::lag()

Thanks


#21

Hi
I’ve been having trouble having upgraded to tidyverse 1.2.1 - I get this:

library(tidyverse)
Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘Rcpp’
In addition: Warning message:
package ‘tidyverse’ was built under R version 3.4.3

I don’t think I ever upgraded to 1.2 so can’t comment on whether that was also a problem for me.

Should I go back to 1.2.1?