Tried install_github("hfgolino/EGA", dep = TRUE) getting error "Installation failed: SSLRead() return error -9806"

package-installation
ega
#1

Hello,

I used the above code (install_github("hfgolino/EGA", dep = TRUE) but got the following warning:

Installation failed: SSLRead() return error -9806

I repeatedly tried to upload the EGA package but didn't succeed; would you help me with that?

Ty very much!

0 Likes

Unable to install EGA exploratory graph analysis pacakge https://github.com/hfgolino/EGA
#2

This sounds like a curl problem, do you have the latest versions of curl and httr packages? If not, try updating them first.

Also, is your internet connection behind a proxy server or firewall?

0 Likes

#3

I upgraded curl and httr packages but the problem remains: in fact, the whole message I receive is as follows:

library(devtools)
devtools::install_github('hfgolino/EGA')
Downloading GitHub repo hfgolino/EGA@master
from URL https://api.github.com/repos/hfgolino/EGA/zipball/master
Installing EGA
'/Library/Frameworks/R.framework/Resources/bin/R' --no-site-file --no-environ --no-save --no-restore --quiet CMD INSTALL
'/private/var/folders/r_/7px1g23x20d2m14sp0pr7y780000gn/T/RtmpAaJq63/devtoolsc4417ec201d/hfgolino-EGA-6dc19f3'
--library='/Library/Frameworks/R.framework/Versions/3.3/Resources/library' --install-tests

  • installing source package ‘EGA’ ...
    ** R
    ** data
    *** moving datasets to lazyload DB
    ** preparing package for lazy loading
    Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
    namespace ‘dplyr’ 0.7.4 is being loaded, but >= 0.7.8 is required
    ERROR: lazy loading failed for package ‘EGA’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.3/Resources/library/EGA’
  • restoring previous ‘/Library/Frameworks/R.framework/Versions/3.3/Resources/library/EGA’
    Installation failed: Command failed (1)

As far as I know, the proxy server is not blocking any service in R...but, how can I be sure of that?

Thanks a lot :slight_smile:

0 Likes

#4

This is a completely different error, now your problem is that you have to update dplyr before installing EGA

install.packages("dplyr")

Also, you are using a fairly old version of R, if you update to the latest version (3.5.2) you'll have access to precompiled binaries which will make the installation process for several packages faster and simpler.

0 Likes

#5

Wow, I tried it before posting my doubts and it didnt work - but now it did! I upgraded the "dyplr" package and the "EGA".

Thanks a lot :slight_smile:

0 Likes

#6

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

0 Likes

closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

0 Likes