Trouble setting up tensorflow on RStudio Cloud

I am trying to use tensorflow in a fresh new RStudio Cloud project.


Installation seems to proceed smoothly enough, but tensorflow::tf_version() crashes my R session. When I install Python's TensorFlow through Miniconda, Sometimes I see *** Error in /usr/lib/rstudio-server/bin/rsession': munmap_chunk(): invalid pointer: 0x00007ffd59ea4240 ***` before the crash. I tried CRAN tensorflow (version 2.0.0) and The RStudio Cloud project is available at

Related: Persistent Python environment for RStudio Cloud projects

Sorry to hear about your trouble!! This is a known issue with RStudio 1.2, although I know little more than that. Hopefully either (1) somebody can chime in with a workaround or (2) we will update to 1.3 before too long and have this issue resolved :smile:

1 Like

I never would have guessed! Is it possible to downgrade the version of RStudio IDE in an individual Cloud project?

@wlandau If you're interested, you can follow the progress on the issue at . So far it's mostly research, reproduction, and investigation.

1 Like

I will have to defer to someone who knows better than I! That said, I know there has been at least some traction on moving to RStudio 1.3, so that may be on the near horizon as well.

EDIT: I have asked internally for someone with more knowledge of the particulars to review.

Small update without a clear timeline: it is unfortunately not possible today to customize the RSP version for a single workspace.

RSP 1.3 is on the way, but there is no clear expectation of timeline due to some other more pressing priorities :slight_smile:

@rblum Did you ever find out what allowed the one RSP 1.2 server to work for you without the crash? Was it a different version of tensorflow, python, etc.?

1 Like

Just posted here to ask around.

I figured it out! All I needed was to downgrade to TensorFlow 1.13.1. I thought I already tried that, but then I realized install_keras() silently upgrades TensorFlow unless I supply a version string to the tensorflow argument. My current setup script for Cloud is here.

1 Like

Woohoo!! Well done!! Apologies for the trouble, sir! We will keep working on a solution / upgrade to 1.3 so that all versions of TensorFlow work! :smile:

And thanks for narrowing down the culprit of our bug, which is still at large! If 1.13.1 is working, something after that must be clashing with the IDE.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.