trouble using mutate and other functions after update

Hi there,
I am relatively new to using tidyverse packages. After great success yesterday, I ran into issues today after updating some packages when installing plotly.

Earlier today I was having no trouble running the following code and producing a bar graph.

june<-read.csv("june_EUKinteractionsummary.csv", header = TRUE)
tidyjun %>% group_by(key,value) %>% tally(sort=TRUE) %>% filter(value!="") %>%
  ggplot(aes(x=key,y=n,fill=value)) + geom_bar(stat="identity",color="black",size=0.2)

Now, when I try and run this I get the following error.

Error in arrange_impl(.data, dots) : 
  Evaluation error: `as_dictionary()` is defunct as of rlang 0.3.0.
Please use `as_data_pronoun()` instead.

Or when I run:

tidyjun %>% group_by(key,value) %>% 
  tally %>%
  mutate(value = ifelse(n < 20, "Taxa with <20 interactions", value)) %>%
  group_by(key, value) %>%
  summarize(n = sum(n)) %>%
  filter(value!="") %>%
  mutate(value=factor(value, levels=c("A","B","C","D","E","F","Taxa with <20 interactions"))) %>%
  ggplot(aes(x=key,y=n,fill=value)) + geom_bar(stat="identity",color="black",size=0.2) + labs(title="June Eukaryotic Interaction Breakdown", y="Number of Edges") + theme(legend.position="bottom")

I get the following error:

Error in mutate_impl(.data, dots) : 
  Evaluation error: `as_dictionary()` is defunct as of rlang 0.3.0.
Please use `as_data_pronoun()` instead.

Does anyone know of a work around for this or a way I can change my code so that it it works again. I have a feeling that a lot of the code I have for ggplot2 and dplyr won't work anymore now....

Thank you so much!

Nevermind. I think I fixed it (for now) by updating RStudio! We'll see if this does the trick as I continue to work on this project.

1 Like

Which version of RStudio did you get? - I have massive problems with the last update of Tidyverse

I'm having the same error:

Error in mutate_impl(.data, dots) :
Evaluation error: as_dictionary() is defunct as of rlang 0.3.0.
Please use as_data_pronoun() instead.

It only happens for me when I use "mutate" in dplyr. The weird thing is that the metrics I'm mutating are all numeric as well so I'm not sure why any text-related commands would be called. I've never seen it before so I'm guessing it's from this update as well. I'm going to see if I can update R and if that will help. Also, I have Ubuntu 16.04. I'm not sure if my OS would have any relevance, but there it is anyway.

I hit the same problem using "filter" in dplyr as well.

Tried updating R and dplyr. No luck. Same error.

Could you try updating your packages and retrying your problematic code?

update.packages(ask = FALSE, checkBuilt = TRUE)

If this false, could you provide a reproducible example of the error, along with system information?

system Information

#### System Information:
- RStudio Edition: (Desktop or Server)
- RStudio Version: 
- OS Version: 
- R Version: 

#### Also:
<!-- Depending on your issue, the following may be useful /-->
<!-- If a section isn't relevant or you can't collect it just delete that section below /-->
- RStudio diagnostics report: <!--see /-->
- Your `sessionInfo()`:
- RStudio crash report: <!-- /-->
- RStudio application log files: <!-- /-->

A post was split to a new topic: error message with as_data_pronoun and %>% arrange()

A post was split to a new topic: Mutate Evaluation error: objet '...' introuvable."