Trying to instal seurat package via github but get non-zero exit status

I am trying to install an R package from the GitHub site: https://github.com/satijalab/seurat-data
But when I copy the code in Rstudio on my mac is get the error of non-zero exit status.

The system I am currently running on:
MacBook Pro: version 10.15.3
R build: 3.6.2
R studio: 1.2.5

Here's the error message:

devtools::install_github('satijalab/seurat-data')
Downloading GitHub repo satijalab/seurat-data@master
✓ checking for file ‘/private/var/folders/f8/78t0b7150bx_g6_nkngrblw40000gn/T/Rtmp3wiZWC/remotes40516a06c6a/satijalab-seurat-data-12c77a8/DESCRIPTION’ ...
─ preparing ‘SeuratData’:
✓ checking DESCRIPTION meta-information ...
─ checking for LF line-endings in source and make files and shell scripts
─ checking for empty or unneeded directories
─ building ‘SeuratData_0.2.1.tar.gz’

  • installing source package ‘SeuratData’ ...
    ** using staged installation
    ** R
    ** exec
    ** inst
    ** byte-compile and prepare package for lazy loading
    ** help
    *** installing help indices
    ** building package indices
    ** testing if installed package can be loaded from temporary location
    Error: package or namespace load failed for ‘SeuratData’:
    .onAttach failed in attachNamespace() for 'SeuratData', details:
    call: x[[2]]
    error: subscript out of bounds
    Error: loading failed
    Execution halted
    ERROR: loading failed
  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/SeuratData’
    Error: Failed to install 'SeuratData' from GitHub:
    (converted from warning) installation of package ‘/var/folders/f8/78t0b7150bx_g6_nkngrblw40000gn/T//Rtmp3wiZWC/file4057e2daec0/SeuratData_0.2.1.tar.gz’ had non-zero exit status

I have also tried in R but got the same error.

Kind regards

Kevin

Hi, and welcome!

For future reference, please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers. Not needed for this question, though!

We have the same setup and I get the same error

I get the same error in Ubuntu, so it's a problem with the package.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.