Turn off authorization for /__api__/me, or add robots.txt file (SEO)

How can I turn off authorization for the /api/me extension of my website? When I google my website (www.dynamicfit.app) it tells me there is an issue with the /api/me extension, such that "Server error response: [24] The requested operation requires authentication.". This creates an error in Google search and makes it such that Google fails to display my website in Google search results.

Alternatively, where would I add a robots.txt file in RStudio Connect that I can use to tell google to ignore this page? I'm not sure where the "root" is on RStudio Connect, given that my landing page and apps are stored in different folders. I tried adding a robots.txt file to /var/lib/rstudio-connect but the website doesn't recognize it, and I can't deploy a text file as an app from RStudio.

Update: I think it might belong at /opt/rstudio-connect/ui/dashboard. However, the robots.txt file loads from dynamicfit.app/connect/robots.txt, and I'm not sure if that's the same as dynamicfit.app/robots.txt.

Alternatively - where is the .html file for the /app/me link? If I can access that, I could add noindex to the meta.

Woops! So sorry for missing this, and thanks for the heads up!

I'll share this with our team and see if they can come up with any creative ideas. You're exactly right that we get into a bit of a sticky place here because (even though you can host a text file as a standalone app on RSC) you cannot host apps at / or /robots.txt.

Do you have a proxy of some stripe in front of RStudio Connect? That would be one option for injecting the robots.txt file that would not depend on us exposing such behavior. Unfortunately, I am not optimistic about potential for altering the __api__/me URL (which is an API request).

Apologies for your trouble (and the long delay!)!