Unable to access index for repository for dslabs

Hi guys,

I'm completely new to R and cannot even install dslabs :smiley: This is the error I'm getting:

Warning in install.packages :
unable to access index for repository http:// cran.rstudio. com /src/contrib:
cannot open URL 'http:// cran. rstudio. com/src/contrib/PACKAGES'

As far as I'm concerned, the problem might be my company's firewall but I was hoping you could help me understand it and give some directions. I did my homework and tried a lot of fixes on the internet (e.g. checking out secure download and IE proxy in the global options). I also tried downloading packages and installing them from my disk, but it involves an insanely long chaing of dependencies. When trying to change mirror, I'm getting another error:

Warning message:
In download.file(url, destfile = f, quiet = TRUE) :
InternetOpenUrl failed: 'A connection with the server could not be established'

Do you know if I can somehow confirm if that's the firewall's issue and maybe somehow whitelist the cran mirror (I'm really guessing here but maybe with some CLI commands - "ping www.cran.rstudio.com" doesn't seem to be working)?

try in your browser to navigate to the URL
it should show you a long but simple text result

It shows a very long, but otherwise nice list of all the available packages like so:

Package: AATtools
Version: 0.0.1
Depends: R (>= 3.6.0)
Imports: magrittr, dplyr, doParallel, foreach
License: GPL-3
MD5sum: 3bd92dbd94573afb17ebc5eab23473cb
NeedsCompilation: no

So, I guess the firewall might not be the issue.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.