Unable to access index for repository (Internet Explorer disabled)

We use a proxy server in our company to reload packages in RStudio. Recently, Internet Explorer was disabled because Microsoft stopped supporting IE. Since then, we have not been able to reload packages. Probably this worked without problems until now, because under

  • Options > Packages > "Use Internet Explorer library for http proxy"
    was activated.

As a workaround we now have the file: ~/.Renviron and configured the proxy there manually. Also the URL cran.rstudio.com had to be made accessible at the proxy without authentication. So far this was not necessary, because the previous option probably used the credentials of Windows to authenticate at the proxy.

Is there a possibility to add a proxy authentication via NTLM / Kerberos in the file '~/.Renviron' without storing the user data and passwords in the configuration?

Or is there an alternative to the option used so far ("Use Internet Explorer library for http proxy"), so that e.g. the Windows proxy settings are used?

We also run an SSL traffic scan on the proxy, replacing the certificates from cran.rstudio.com with the company's own certificates. If the option "Use Secure Download method for http" is enabled, the download fails. Probably because rStudio does not trust the company's own certificates.

Is there a possibility to store own certificates for downloading the packages?

Thanks for any hint.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.