Unable to deploy app on shinyapp.io

shiny
shinyappsio

#1

I am unable to deploy my app. The message in my 'Deploy' tab in RStudio is as below

"----- Deployment log started at 2018-10-01 21:17:42 -----
Deploy command:
rsconnect::deployApp(appDir = "~/projects/tvet", appFileManifest = "/var/folders/zt/3d0mxlms2gn50by8f1jshzym0000gn/T/2778-6d28-98a7-47cd", account = "pico", server = "shinyapps.io", appName = "tvet", appTitle = "tvet", launch.browser = function(url) { message("Deployment completed: ", url) }, lint = FALSE, metadata = list(asMultiple = FALSE, asStatic = FALSE), logLevel = "verbose")

Session information:
R version 3.5.1 (2018-07-02)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS High Sierra 10.13.6

Matrix products: default
BLAS: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libRblas.0.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libRlapack.dylib

locale:
[1] en_GB.UTF-8/en_GB.UTF-8/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_3.5.1 rsconnect_0.8.8
Cookies:
[1] "None"
GET /v1/applications/465499 2248ms
----- Deployment error -----
Error: HTTP 404
GET https://api.shinyapps.io/v1/applications/465499
Not Found

----- Error stack trace -----
8: stop("HTTP ", response$status, "\n", response$req$method, " ",
response$req$protocol, "://", response$req$host, response$req$port,
response$req$path, "\n", msg, call. = FALSE)
7: reportError(json$error)
6: handleResponse(GET(service, authInfo, path))
5: client$getApplication(target$appId)
4: applicationForTarget(client, accountDetails, target, forceUpdate)
3: force(code)
2: withStatus(paste0("Preparing to deploy ", assetTypeName), {
application <- applicationForTarget(client, accountDetails,
target, forceUpdate)
})
1: rsconnect::deployApp(appDir = "~/projects/tvet", appFileManifest = "/var/folders/zt/3d0mxlms2gn50by8f1jshzym0000gn/T/2778-6d28-98a7-47cd",
account = "pico", server = "shinyapps.io", appName = "tvet",
appTitle = "tvet", launch.browser = function(url) {
message("Deployment completed: ", url)
}, lint = FALSE, metadata = list(asMultiple = FALSE, asStatic = FALSE),
logLevel = "verbose")
Error: HTTP 404
GET https://api.shinyapps.io/v1/applications/465499
Not Found
Execution halted"

Please assist.


#2

Did you previously delete the application deployed from that directory?
If so, you will need to remove the locally cached deployment information before redeploying.

If you are using the development version of rsconnect from GitHub, it will have a new function, forgetDeployment. Otherwise, you will need to manually delete the ./rsconnect/shinyapps.io/<account name>/<app name>.dcf file.


Error HTTP 404 (after deleting application)
#3

Dear Josh

I did delete the application.

Thank you for your response.

Sincerely