Unable to deploy app: Unable to determine package source

Dear community,
I have an embarrassing error when deploy a simple app to shinyapps.io.
The app needs only one more package "Seurat" which I load in server.R by library(Seurat). But When I deploy it to shinyappsio.io, it stopped and showed:

Deploying bundle: 2802015 for application: 1762339 ...
Waiting for task: 692556838
  building: Processing bundle: 2802015
  building: Parsing manifest
################################ Begin Task Log ################################ 
################################# End Task Log ################################# 
Error: Unhandled Exception: Child Task 692556840 failed: Error parsing manifest: Unable to determine package source for Bioconductor package Seurat: Repository must be specified
Execution halted

While it seems to be a simple repository specification problem. So I tried changing the repos:

options(repos = BiocManager::repositories())

which didn't help, then I tried:

setRepositories()

and choose the "BioC software" and it doesn't help either.

Then I found Seurat is even not a bioconductor package and should be found with r CRAN.

I have no other solution in my head. Could anyone help me out? Thank you!

Here's current options("repos"):

> options("repos")
$repos
                                                BioCsoft                                                  BioCann 
           "https://bioconductor.org/packages/3.10/bioc" "https://bioconductor.org/packages/3.10/data/annotation" 
                                                 BioCexp                                            BioCworkflows 
"https://bioconductor.org/packages/3.10/data/experiment"       "https://bioconductor.org/packages/3.10/workflows"

Here's my sessioninfo:

R version 3.6.2 (2019-12-12)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 18.04.4 LTS

Matrix products: default
BLAS:   /usr/lib/x86_64-linux-gnu/blas/libblas.so.3.7.1
LAPACK: /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3.7.1

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C               LC_TIME=en_GB.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=en_GB.UTF-8    LC_MESSAGES=en_US.UTF-8    LC_PAPER=en_GB.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C             LC_MEASUREMENT=en_GB.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
 [1] Rcpp_1.0.3          rstudioapi_0.11     MASS_7.3-51.5       lattice_0.20-38     fansi_0.4.1         ROCR_1.0-7         
 [7] caTools_1.18.0      tools_3.6.2         grid_3.6.2          packrat_0.5.0       sessioninfo_1.1.1   KernSmooth_2.23-16 
[13] cli_2.0.1           withr_2.1.2         askpass_1.1         gtools_3.8.1        assertthat_0.2.1    openssl_1.4.1      
[19] digest_0.6.24       crayon_1.3.4        Matrix_1.2-18       BiocManager_1.30.10 RColorBrewer_1.1-2  bitops_1.0-6       
[25] rsconnect_0.8.16    curl_4.3            glue_1.3.1          stringi_1.4.5       gdata_2.18.0        compiler_3.6.2     
[31] gplots_3.0.1.2      jsonlite_1.6.1      RANN_2.6.1         

I'm just barely figuring this stuff out myself, but it looks to me like CRAN is missing from your repos.

If I run options(repos = BiocManager::repositories()) and then options("repos"), I get the same four BioConductor repos plus CRAN.

$repos
                                               BioCsoft 
           "https://bioconductor.org/packages/3.9/bioc" 
                                                BioCann 
"https://bioconductor.org/packages/3.9/data/annotation" 
                                                BioCexp 
"https://bioconductor.org/packages/3.9/data/experiment" 
                                          BioCworkflows 
      "https://bioconductor.org/packages/3.9/workflows" 
                                                   CRAN 
                            "https://cran.rstudio.com/" 

Hi KatherineCox,
Thank you for help. But what ever my options("repos") is, it still doesn't work.
I changed to the repos like yours:

> options("repos")
$repos
                                                    CRAN 
                           "https://cloud.r-project.org" 
                                                BioCsoft 
           "https://bioconductor.org/packages/3.10/bioc" 
                                                 BioCann 
"https://bioconductor.org/packages/3.10/data/annotation" 
                                                 BioCexp 
"https://bioconductor.org/packages/3.10/data/experiment" 

Still cannot work.

but the package is clearly in r cran:
https://cran.r-project.org/web/packages/Seurat/index.html

I don't know how to figure it out.

Since you specified repos including cran, the error is the same as originally posted, or changed in some way?

Hi,
You're right. There's slight different when I change the repos:

When repos is default (only r-cran)

> options("repos")
$repos
                         CRAN 
"https://cloud.r-project.org"

It gives:

Preparing to deploy application...DONE
Uploading bundle for application: 1762339...DONE
Deploying bundle: 2806268 for application: 1762339 ...
Waiting for task: 693229180
  building: Processing bundle: 2806268
  building: Parsing manifest
################################ Begin Task Log ################################ 
################################# End Task Log ################################# 
Error: Unhandled Exception: Child Task 693229181 failed: Error parsing manifest: Unable to determine package source for Bioconductor package Biobase: Repository must be specified
Execution halted

When I specified bioconductor:

$repos
                                                    CRAN                                                 BioCsoft 
                           "https://cloud.r-project.org"            "https://bioconductor.org/packages/3.10/bioc" 
                                                 BioCann                                                  BioCexp 
"https://bioconductor.org/packages/3.10/data/annotation" "https://bioconductor.org/packages/3.10/data/experiment" 

Deploy and it says:

Preparing to deploy application...DONE
Uploading bundle for application: 1762339...DONE
Deploying bundle: 2806287 for application: 1762339 ...
Waiting for task: 693231225
  building: Processing bundle: 2806287
  building: Parsing manifest
################################ Begin Task Log ################################ 
################################# End Task Log ################################# 
Error: Unhandled Exception: Child Task 693231227 failed: Error parsing manifest: Unable to determine package source for Bioconductor package Seurat: Repository must be specified
Execution halted

For the default repos (only r cran) it was for "Bioconductor package Biobase".
For the changed repos (with bioc etc. ) it specified for "Bioconductor package Seurat".

I tried also uninstalling Seurat package from my computer and reinstalling it only via CRAN or only via Bioconductor.
Neither works.
Can anyone help or did anyone have similar problem?