Unable to deploy my shinyapp

Hello
I am getting stuck at the very beginning of my app deployment
the feedback is this error:

Preparing to deploy application...DONE
Uploading bundle for application: 1556174...Error in biocPackages[pkg, "Repository"] : subscript out of bounds
Calls: ... createAppManifest -> snapshotDependencies -> lapply -> FUN
Execution halted

I guess the problem is with packages declared in the source. This is the current list:
library(shiny)
library(shinythemes)
library(shinydashboard)
library(shinycssloaders)
library(shinyWidgets)
library(shinyBS)

library(DT)
library(tidyverse)
library(lubridate)
library(plotly)
library(RColorBrewer)
library(reshape2)
library(rhandsontable)
#library(ggrepel)
#library(heatmaply)
library(pheatmap)
library(png) # these are for plotting on a grid the png files
library(grid)
library(gridExtra)
library(streamgraph)

library(openCyto)
library(flowViz)
library(ggcyto)
library(flowAI)
#library(scales) #maybe to be added for the flowStats transformation
#see https://bioconductor.org/packages/release/bioc/vignettes/flowWorkspace/inst/doc/flowWorkspace-Introduction.html
library(flowStats)
library(spade) #https://github.com/nolanlab/spade the installation is based on github
library(limma)
library(matrixStats)
library(factoextra)
library(mclust)
library(FlowSOM)
library(ConsensusClusterPlus)
library(Rtsne)
library(umap)

Pity, I do not have any application log since it is still in "undeployed" state
I am not using packarat

  • Cite output of "rsconnect::appDependencies()"
    rsrsconnect ver. 0.8.15
    rStudio 1.2.1578
    R version 3.6.1

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.