Unable to Install lubridate

Error Information:

Error: package or namespace load failed for ‘lubridate’ in inDL(x, as.logical(local), as.logical(now), ...):
unable to load shared object 'C:/Users/KUMR/Documents/R/win-library/4.0/Rcpp/libs/x64/Rcpp.dll':
LoadLibrary failure: The specified procedure could not be found.

Description of issue -
I've been trying to install the lubridate package, but continuously receive the error message noted above. I updated Rstudio in the hopes of fixing the issue, but now ALL of my packages "cannot be located in the dynamic link library". I am using a university computer, so I am not the administrator, but have tried to set my own path. Please help!

Steps taken so far -

.libPaths("/Users/KUMR/Documents/R/win-library/4.0")
.libPaths("C:/Users/KUMR/Documents/R/win-library/4.0")
.libPaths("C:/Users/KUMR/Documents/R/win-library/4.0")
.libPaths(c("C:/Users/KUMR/Documents/R/win-library/4.0",.libPaths()))

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.3.1056
  • OS Version:
  • R Version: 4.0

Also:

  • RStudio diagnostics report:
  • Your sessionInfo():
  • RStudio crash report:
  • RStudio application log files:

From Troubleshooting Guide: Using RStudio

Try installing Rcpp first, then lubridate

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Its hard to advise you when you report that 'it didnt work' without providing a description with details thereof.
However, you mentioned you are not an admin, it may well be that you need support from your admin to fix your issues.

Hi I have already tried this and it still did not work. RStudio will not read any of my other packages.