unable to install packages after update to R 4.2.1

Hi there,
I would need some help with installing packages. Since I made an update to the latest R version 4.2.1.


The downloads don't show any error, but at the end the output is the following:

package ‘colorspace’ successfully unpacked and MD5 sums checked
Error in install.packages : ERROR: failed to lock directory ‘C:\Users\Admin\AppData\Local\R\win-library\4.2’ for modifying
Try removing ‘C:\Users\Admin\AppData\Local\R\win-library\4.2/00LOCK’

library(tidyverse) is therefore also not working:
Error in library(tidyverse) : there is no package called ‘tidyverse’

It does the same with every package I am trying to install. I already deleted 00lock, that didn't work. Then I fully deinstalled R and RStudio and installed both latest version and I have the same problem, additionally I can't find any '00lock' under the indicated directory.
I also tried uninstalling all packages.
Anyone any ideas?
Thank you in advance :slight_smile:


The problem is solved :slight_smile:
There was still a 00lock that I had to manually delete, but the directory was not visible until making it show hidden folders...

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.