Unable to install R packages -internet connection failures?

connection
package-installation

#1

Dear all,

I know similar qquestions have been asked before but all the suggested solutions I read about and that worked for other users failed in my case... I was suddenly no longer able to install R packages on my R version 3.3. and received the following error messsage:

    Warning in install.packages :
    unable to access index for repository http://cran.univ-paris1.fr    src/contrib:
    cannot open URL 'http://cran.univ-paris1.fr/src/contrib/PACKAGES'
    Warning in install.packages

I already tried several different mirrors which did not work. I even updated my R to the newest version (3.5.1) which also did not help. I changed the general options and unselected "secure download method for HTTP" and also "use internet explorer library/proxy for http")- without any success. Lastely, I was running "options(repos="my_favorite_CRAN_mirror")" before trying to install a package but it also failed.

Does anyone have an idea what else I could try? Any help would be highly appreciated!!! Thanks a lot!

Best wishes,
Belinda


#2

This definitely an issue of internet connectivity. You may had set up the correct config in your old R version. Check the R profile.site

You may have a proxy that blocking you. Do you know of anything? Are you in company network?

Also try https://cran.rstudio.com, this mirror will use the closest one available. It is a good choice.


#3

Hello,

thanks for the quick response. I checked the Rprofile.site file but it looks okay or at least I cannot see a difference to a file from my colleague for which R is working correctly. Yes, I already tried specifying the repository when downloading a package- it also fails.
I switched off my firewall already, so it shouldn't be an issue. however, how can I test if R is able to connect with the internet or if there is something blocking the connection?
Thank you!


#4

You can try to read a file from an url, download a file with download.file, see if you have status 200 with httr::GET On any page. (Or with curl :package:)