Unable to install "xcode-select" command line developer tools on MacBook Air


This is a new user of R.

An attempt was made to install xgboost in R studio on MacBook Air via the code devtools::install_github("pmontman/customxgboost")


However, no tools are available to compile the package

I also entered the code pkgbuild::check_build_tools(debug = TRUE), but error was shown in the following screenshot.

I tried to manually install the required command line developer tools for R on MacBook Air, but not sure where they are available.

Much appreciated if some ideas could be provided.

This is outside R.

You will need the XCode app from the App Store. When it is finally finished (it may take an hour depending on connection speed, etc.), open a terminal window

$ xcode-select --install

and then you may be able to install R packages that require compiling from source. Whenever you run install.packages("something") and you are greeted by "a binary version is available but a source version is later", you may, if you choose, select the option to install from source and that might work. If, however, it does not work the first time there is little chance it will work on a second attempt.

Thank you very much. It works now.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.