Unable to intsall RAM package.

I am trying to install the following package:

RAM: R for Amplicon-Sequencing-Based Microbial-Ecology

(RAM: R for Amplicon-Sequencing-Based Microbial-Ecology version from CRAN)

I get the following error:

Warning in install.packages :
package ‘RAM’ is not available for this version of R

A version of this package for your version of R might be available elsewhere,
see the ideas at

I then downloaded the RAM_1.2.1.7.tar.gz from the following website

Index of /src/contrib/Archive/RAM

I tried installing the package like this:

I get the following error:

install.packages("~/Downloads/RAM_1.2.1.7.tar.gz", repos = NULL, type = "source")
ERROR: dependencies ‘vegan’, ‘ggplot2’, ‘gplots’, ‘labdsv’, ‘gridExtra’, ‘ggmap’, ‘VennDiagram’, ‘FD’, ‘RgoogleMaps’, ‘reshape’, ‘ade4’, ‘phangorn’, ‘phytools’, ‘ape’ are not available for package ‘RAM’

  • removing ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/RAM’
    Warning in install.packages :
    installation of package ‘/Users/hiraabid/Downloads/RAM_1.2.1.7.tar.gz’ had non-zero exit status

I am using the following version of rstudio on Mac OS

Please help me with the installation of this package.

This package seems to be abandoned since it doesn't have any update since 2018 and it is not currently passing CRAN checks.

You can try to install it from the GitHub mirror but there is no guarantee that it is going to work with the latest R version.


If it doesn't work you could try to downgrade R to an older version.

1 Like

Thank you very much. This worked for me. I installed it successfully. :slight_smile:

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.