Unable to knit because I need rmarkdown but it won't download

I am unable to knit without rmarkdown so I downloaded it and tried again. I then got a new error message saying I need an updated version of rmarkdown even though I just downloaded it and am unable to figure out how to resolve this.

I get this output
ARGUMENT 'sys.source('/usr/lib/rstudio-server/R/modules/SourceWithProgress.R',~+~envir~+~=~+~as.environment('tools:rstudio'));' ignored
ARGUMENT '.rs.sourceWithProgress(' ignored
ARGUMENT '~+++~script~+~=~+~'/tmp/21bd-d019-d396-9192',' ignored
ARGUMENT '~+++~encoding~+~=~+~'UTF-8',' ignored
ARGUMENT '~+++~con~+~=~+~stdout(),' ignored
ARGUMENT '~+++~importRdata~+~=~+~NULL,' ignored
ARGUMENT '~+++~exportRdata~+~=~+~NULL' ignored
ARGUMENT ')' ignored

How are you trying to knit ?

knit::knit() ? rmarkdown::render() ? Or using a button in RStudio IDE maybe ? Something else ?

From this, I am guessing RStudio IDE. What is your version ? What did you click to have this error message ?

Knitting a Rmd document from the IDE should run rmarkdown::render() and not sys.source() So I need more context to understand

thank you