Unable to login into rstudio server (1.4.1106 (Tiger Daylily) for CentOS 7)

R version 3.6.0 (2019-04-26) -- "Planting of a Tree"
Copyright (C) 2019 The R Foundation for Statistical Computing
Platform: x86_64-redhat-linux-gnu (64-bit)

rstudio-server version : 1.4.1106 (Tiger Daylily) for CentOS 7
Red Hat Enterprise Linux Server release 7.8 (Maipo)

We have upgraded rstudio server few days back along with the R version. Now the issue coming up with login. Whenever any users enters his credentials he is redirected back to the login page without any errors popping up. This is bit of random, one time we are able to login, and the other time we are not. We have restarted rstudio server multiple times but nothing worked. Also we have tried forcefully killing rsessions but nothing is changing.
We are able to run R shell from command line and also from rstudio server and its working fine. The issue is with randomness of logging in to the rstduio. We haven't configured anything related to the sessions in /etc/rstudio.

Any suggestions or help are much appreciated. I am pretty new to this community, please bug me to get any more details or any solutions that i can try.

Thanks to all in advance for having a strong community for rstudio :slight_smile:

I have experienced this exact same behavior on Ubuntu 20.04 LTS, no error messages either, I think the problem gets more frequent when the client's internet connection is unstable with high latency, I changed of service provider and now the problem is very rare, but I have no proof of this is actually the cause, maybe it's just circumstantial.

Thanks Andrés for responding
Any ideas about RStudio 1.4.1717 "Juliet Rose", June 1st, 2021
Further i didn't see it as high latency issue. I tried with ssh tunnel also and the issue was same. Also all of my friends are facing the same issue. No one was able to login successfully each time they try.

As I said, after changing from internet service provider, the problem has become very rare, I'm using RStudio 1.4.1717 with R 4.1.1 now and haven't experienced the issue in a while. The lack of any error messages makes this hard to investigate, maybe some other people with the same problem would provide more insight.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.