Unable to open Base Package

Several others have posted the issue Fatal Error: Unable to open the base package as noted here.

I have now found myself in the same situation. In my case I believe it was caused when I:

  • Closed R & RStudio
  • Installed latest version of R and uninstalled an older version of R
  • RStudio could not find the version of R that was just uninstalled

My question: why is there not an easy fix for this? Seems like it would make sense to have a pop-up that asks which version of R should RStudio be using - instead of just a blank white screen. In fact I did see this once (not sure how or why) but in my other 15 or so attempts I cannot get back to that option

I tried (1) uninstalling/reinstalling everything, (2) re-installing the version of R that RStudio was looking for previously, and (3) installing different versions of RStudio [current release and preview release] - but no joy.

Please advise and thanks for the help

BTW: Currently working with version 1.4.1717

Have you tried resetting RStudio's state?

On Windows, you can get that by holding the Ctrl key while opening RStudio, then you should see this menu.

This is very helpful - thank you!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.