Unable to Run "modeest" package

Error Information: Unable to run the downloaded package

Description of issue - I am very new to programming and R is the first language i am working on. I am running R Studio on my Laptop and tried to install "modeest" package but couldn't so as it is showing that package has been downloaded successfully but cannot run it. Please find the error message below

package ‘modeest’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in

library("modeest", lib.loc="~/R/win-library/3.5")
Error: package or namespace load failed for ‘modeest’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘genefilter’

Steps taken so far -
Using the latest version of R Studio so don't know what to update further.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.1.463
  • OS Version: Windows 10 Enterprise
  • R Version: 3.5.2


  • RStudio diagnostics report:
  • Your sessionInfo():
  • RStudio crash report:
  • RStudio application log files:

From Troubleshooting Guide: Using RStudio

The error message gives you a clue, "there is no package called ‘genefilter’", you have to install this package from bioconductor
, before installing modeest package.

if (!requireNamespace("BiocManager", quietly = TRUE))
BiocManager::install("genefilter", version = "3.8")

@andresrcs Thanks a lot for notifying the clue. I copied the code you posted. It worked. Thanks a lot once again :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.