Unable to See Git tab in the Environment Quadrant

Hi All, apologies if this question's been done to death. Am running Windows 10, connecting Git and R Studio for the first time, followed all the required steps and nothing, can't generate the Git tab in Studio.

Have installed Git, generated and copied the SSH to GitHub but the created projects in R are not appearing in GitHub. Somewhere the connection isn't being made. I can see one project in GitHub and three Test projects in Studio. Just wondering if anyone had a suggestion step I might be missing. Thanks.

New day - have reinstalled R, RStudio and Git, and no change. Git still won't appear in RStudio. Something is wrong between Git, RStudio and Windows. For now, I've stopped working with R Studio.

Can you clone a project within RStudio? If not, there is some manual configuration possible.

I don't understand that. Do you mean files called Test.Rproj?

Hi Alexis, Kind thanks for replying. I'm going to start this from the top. There seems to be a 100 ways to link RStudio to Git to GitHub, but here's my process so far.

  1. Created a windows folder - R Projects
  2. Installed R, RStudio, Git, and created a GitHub acc.
  3. Created the same repository in Github - R Projects.
  4. from RStudio > Global Settings > I generated an SSH RSA key.
  5. Pasted this key to GitHub, then, under the Repository, I copied the Push code for Git Bash.
    (and this might be where I'm going wrong)
  6. In Git Bash, I pasted in the push code and got:

Bpublish@DESKTOP-0TSM35B MINGW64 ~ (main)
^[[200~git remote add origin https://github.com/mk2mkt/R-Projects.git bash: '\E[200~git': command not found

Bpublish@DESKTOP-0TSM35B MINGW64 ~ (main)
$ git branch -M main

Bpublish@DESKTOP-0TSM35B MINGW64 ~ (main)
$ git push -u origin main~

And this is where I'm at. Thanks if you have any insight.

So, it does work as expected from the CLI?

Now, if you open RStudio, go to "File > New Project...", do you have a "Version Control" option?

Then, if you select "New Directory", then "New Project", do you have the "create a git repository" checkbox?


Hi Alexis, I did that process, still, no Git has appeared.

R Studio Repository

But do you have the "Import project from Version Control" and Create Project with a git repo" options?

Yes, I have those and followed that process to create my project.

And in that project directory, is there a hidden subdirectory called .git?

Yes, there is. Can see it.

Git folder

OK, then let's first try this: open the R project, then select View > Show Git (just in case the tab is hidden somehow).

If this doesn't work, create a new Project (without git), then run usethis::use_git() and see what happens. If you get the questions, say Yes to creating .gitignore and committing, and Yes to restarting.

Trying option 2 now. View had no 'Show Git' per the screenshot.

Created a new project per below.


This is what came back:

It is possible that the problem is that RStudio's Git interface has been disabled, or that it is not able to find your Git installation.

Can you go to Tools -> Options -> Git/SVN and ensure that:

  • "Enable version control interface" is checked at the top
  • The "Git executable" is pointing to the version of git you want to use
1 Like

Hi Jonathan, I initially did that with no effect. Interestingly though, the SSH key keeps defaulting to this 'ed' version rather than the RSA key I generated and applied earlier.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.