"Unexpected response from server" independent of file size, project or project folder

#1

For the last week or so, I'm unable to upload new files into any project in Rstudio.cloud (private project, share projects, etc...).

I am continually running into this error message:

Here's a public project where I'm encountering this issue: https://rstudio.cloud/project/216187

I've tried about every clear/restart/update option I can find to resolve the error, but no luck.

Prior to encountering this error, I had attempted to load a handful of larger datasets (300MB+) into a project unsuccessfully.

0 Likes

#2

I ran into the same issue and had deliverables for a project. So i made use of git option.
I uploaded files/code from local to git and pulled it into the Rstudio server. Git for Rstudio is easy.

0 Likes

#3

Good to know there's a backup option via Git. Thanks @dataqueen

Update on troubleshooting:

  • I'm using Chrome as a default browser
  • Was able to successfully load data prior to this issue via Chrome
  • Attempted to upload file from FireFox and Edge into same project and upload was successful!
  • Cleared cache and cookies and a number of other settings in chrome. Restarted, reloaded Rstudio/project, and attempted to upload a file and hit same error message again.

I'm hoping for a solution for how to get my default browser back up and running w/ Rstudio.cloud, but can use Firefox if needed (at least for uploading files).

0 Likes

#4

Just had my own project implode on rstudio.cloud; I suspect I'll have to get this done once the project is restored, or when I redo things again...

0 Likes

#5

Hello,

I'm sorry you are hitting this. I think this is a bug that we are working on fixing. During file uploading the IDE will buffer the file into memory - and that can cause the upload the fail due to our 1GB memory limit on a container in cloud.

The git work around is a good approach. Alternatively you can expose the file through a storage service like drop box and download it through the terminal using scp for larger files.

Sean

0 Likes

#6

Thanks for the response @seans

Just to confirm, I'm trying to upload files roughly 100kbs in size. Simple .csv and .Rmd files.

0 Likes

#7

Are you able to share one of the files that is failing for you? If you don't want to share publicly, could you DM @seans or myself?

0 Likes

#8

I'd be happy to, but I can't seem to figure out how to DM. Perhaps since I'm so new to the community, I'm not permitted to yet? If you DM me, I'd be happy to reply with the Rmd and csv files I've been trying to upload.

0 Likes

#9

I just taught a class of ~20 students, and 1 out of 20 of them was having this same problem. He was using Chrome, and eventually we saw this thread and he tried again on another browser, but it does seem to be a server error that is limited to a particular user account. I'm happy to send along the file(s) we were trying to upload, but the other 19 students had no problem, on a range of browsers and OSs.

2 Likes

closed #10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

0 Likes