unfindable pgirmess

hello ! I am currently trying to download the package pgirmess but I have only an error message from the system saying he can't find it.

install.packages(pgirmess)
Error in install.packages : objet 'pgirmess' introuvable

I am sorry, I use R Studio in french... I you can help me, I would be very grateful, I am a student and this is for a homework.

You have to use quotes

install.packages("pgirmess")

What error message you get if you try to install rgdal?

install.packages("rgdal")

Thank you very much with your answer, I did it with pgrimess and this solved the problem. You saved my day ! :smile:
I can now finish my homework. :relaxed:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

well, I thought that solved it (thanks by the way, that was a silly mistake :sweat_smile:), but when I tried to use it :

library("pgirmess")
Erreur : package or namespace load failed for ‘pgirmess’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
aucun package nommé ‘rgdal’ n'est trouvé -> this mean he can't find "rgdal"

when I tried to charge rgdal this didn't change anything. An answer ?

This means that an error has occurred and rgdal has not been installed

You are trying to install the latest version from source but you are missing the gdal library, you would have to install it first (in your system not in R), unfortunately I can't tell you how since I'm not a macOS user.

Another option is to install the binary version that is a little older but doesn't require you to install the missing system library. You can do it by answering "no" to this question.

it is not in installing rgdal but in openening it

install.packages("rgdal")

There is a binary version available but the source version is later:
binary source needs_compilation
rgdal 1.4-8 1.5-18 TRUE

Do you want to install from sources the package which needs compilation? (Yes/no/cancel) yes
installing the source package ‘rgdal’

essai de l'URL 'https://cran.rstudio.com/src/contrib/rgdal_1.5-18.tar.gz'
Content type 'application/x-gzip' length 4388549 bytes (4.2 MB)

downloaded 4.2 MB

  • installing source package ‘rgdal’ ...
    ** package ‘rgdal’ correctement décompressé et sommes MD5 vérifiées
    configure: R_HOME: /Library/Frameworks/R.framework/Resources
    configure: CC: clang
    configure: CXX: clang++
    configure: CFLAGS: -Wall -g -O2
    configure: CPPFLAGS: -I/usr/local/include
    configure: CXXFLAGS: -Wall -g -O2
    configure: LDFLAGS: -L/usr/local/lib
    configure: LDFLAGS: -L/usr/local/lib
    configure: CXX11 is: clang++, CXX11STD is: -std=gnu++11
    configure: CXX is: clang++ -std=gnu++11
    configure: C++11 support available
    configure: rgdal: 1.5-18
    checking for /usr/bin/svnversion... yes
    configure: svn revision: 1082
    checking for gdal-config... no
    no
    configure: error: gdal-config not found or not executable.
    ERROR: configuration failed for package ‘rgdal’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/rgdal’
    Warning in install.packages :
    installation of package ‘rgdal’ had non-zero exit status

The downloaded source packages are in
‘/private/var/folders/r7/b3cjb4v52rv33f9dx3crvzxc0000gn/T/RtmplUV65J/downloaded_packages’

library("rgdal")
Error in library("rgdal") : aucun package nommé ‘rgdal’ n'est trouvé