Uninstalling and reinstalling R and RStudio

Split into a new topic from R does not launch properly

I have the same issue. I use RStduio through Anaconda only because Anaconda came with RStudio.

A couple of people on stack overflow also had the issue and identified the cause being a conflict with the latest build of windows 10. (which seems to be my situation) They recommended uninstalling BOTH R and RStudio then re-installing from the respective official sites (and stop using Anaconda). They provided this command to do it - "conda uninstall r-base"

My questions are:
does this command uninstall both?
do I really need to uninstall and reinstall both?
I'm not well versed in using the command line - not sure how I even get to conda...would appreciate guidance on how to do this properly

Thank you!

1 Like

Note that R and RStudio are different. Differentiating R from RStudio, (think of R are the engine, RStudio the car, and you the driver.)
So when you install RStudio you'll need R to be installed to make use of the IDE.

I don't have experience with Anaconda's RStudio install, but to uninstall that in Windows I think you'd go to window's "add and remove programs" tool.

Also, welcome to community.rstudio.com!

Thanks for the quick response!

I do realize that R and RStudio are two different things. That's why I was wondering if its really necessary to also uninstall/re-install R itself or does it suffice to just uninstall RStudio?

Thanks again - so glad I found the community!

1 Like

I've tried using windows to uninstall RStudio but no matter what I do windows doesn't seem to know where the program is - it does not show up in the list of available apps in my control panel - only "R for Windows 3.4.3" (not RStudio) shows up. Anyone else have this issue?

Hi wtalio,
If you don't see rstudio listed in your windows Add or Remove Programs menu, I think that means RStudio is uninstalled.

Here's the support doc on uninstalling RStudio:

Also, before you install RStudio, I think it will be helpful to reset your desktop's state.

Hi EconomiCurtis,

When I go through file explorer I see "RStudio Desktop" in my appdata\local folder on my c drive. Is that the application itself?

The link you kindly provided to reset the desktop state instructs to rename this folder to backup. I tried that and still can't launch.

I encountered a similar situation. The real problem was with the anaconda navigator and anaconda environment maintenance. It just extracts RStudio but does not install it properly. And moreover it creates a shortcut in the start menu. So the proper way to remove it is to manually erase all the contents in the source location and then delete the desktop shortcut in C:\ProgramData\Microsoft\Windows\Start Menu\Programs\RStudio. By now Rstudio would have been completely erased from the computer. Next install RStudio separately from the website and R separately from cran.rproject.org . This created a separate icon in Control Panel's add and remove program window. The stuffs in C:\users\local\appdata are like cache data. Sometime they get erased automatically when a program is installed. But sometime they need to be manually erased after uninstalling a program. And finaly removing Rstudio only removes the IDE, not R completely.