Update all/some/none? [a/s/n]:

packageupdate

#1

image


#2

This is typically a message when trying to install packages from Bioconductor. In most cases, from my experience, you have to select all (by typing a) in order for the package you are trying to install to be installed. However, you are also getting an error about a failure to install foreign and survival. This may occur if the package are already loaded when you try to install them. Try running the install command in a fresh R session by hitting Ctrl+Shift+F10 and then running the install command