Updating RStudio - Missing DLL

I was asked by a client to update their R and RStudio. I installed R 4.0.2 without issue. I updated their Rstudio to 1.1.423 to 1.3.1093. When I open RStudio after the update, I get a 'The program can't start because libwinpthread-1.dll is missing from your computer. Try reinstalling the program to fix this problem.' error message. I can click OK past the message, and RStudio seems to open fine.

This is on Windows Server 2008 R2.

I reinstalled RStudio - No luck
Rolled back to 1.1.423 - Works
Tried installing 1.2.5042 - Same error

I created a new VM of Server 2008R2 that has NOTHING installed, and tried RStudio on that. It installed and opened without issue. I didn't install anything else.

I am not sure what is on the client's server that is causing this error. Is this something anyone can help me out with? R and RStudio are not really in my wheelhouse.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.