/usr/lib/rstudio-server/bin/rserver: /lib64/libpq.so.5: no version information available (required by /usr/lib/rstudio-server/bin/rserver)

This is a persistent bug that appears when I try to start rstudio-server 1.4.1717 (Juliet Rose) for CentOS 8 on Amazon Linux release 2 (Karoo).

Before this bug, there were some libssl and libcrypto missing libraries I successfully symlinked to a homebrew installation

$ rstudio-server start
/usr/lib/rstudio-server/bin/rserver: /lib64/libpq.so.5: no version information available (required by /usr/lib/rstudio-server/bin/rserver)
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to manage system services or units.
Authenticating as: EC2 Default User (ec2-user)
Password: 
==== AUTHENTICATION COMPLETE ===
 $ rstudio-server status
‚óŹ rstudio-server.service - RStudio Server
   Loaded: loaded (/usr/lib/systemd/system/rstudio-server.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Mon 2021-07-19 00:14:50 UTC; 14s ago
  Process: 32055 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=0/SUCCESS)
 Main PID: 32056 (code=exited, status=1/FAILURE)