Version problems when trying to install package 'tmap'

I am running RStudio 3.6.0 in a cloud server (centos linux 7).
When trying to install package tmap the installation fails because of underlying version problems. There are many of them and I just list the first one for simplicity's sake.
It concerns package lwgeom.

* installing *source* package ‘lwgeom’ ...
** package ‘lwgeom’ successfully unpacked and MD5 sums checked
** using staged installation
configure: CC: gcc -m64 -std=gnu99
configure: CXX: g++ -m64 -std=gnu++11
configure: pkg-config proj exists, will use it
configure: PROJ: 4.8.0
checking for pj_init_plus in -lproj... yes
checking PROJ: epsg found and readable... yes
configure: POSTGIS_PROJ_VERSION: 48
checking for geos-config... /usr/bin/geos-config
checking geos-config usability... yes
configure: GEOS: 3.4.2
checking GEOS version >= 3.5.0... no
configure: error: upgrade GEOS to 3.5.0 or later
ERROR: configuration failed for package ‘lwgeom’
* removing ‘/data/arnoldreinders/R/x86_64-redhat-linux-gnu-library/3.6/lwgeom’
Warning in install.packages :
  installation of package ‘lwgeom’ had non-zero exit status
* installing *source* package ‘leafem’ ...
** package ‘leafem’ successfully unpacked and MD5 sums checked
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading

* removing ‘/data/arnoldreinders/R/x86_64-redhat-linux-gnu-library/3.6/leafem’

...etc...

It seems that package lwgeom needs a library geos version 3.5. As I am working on a company cloud server I cannot change the underlying library.
So I tried to install an older package. I ended up by trying to install version 2.2

> install_version('tmap', version='2.2', repos = "http://cran.us.r-project.org")
Downloading package from url: http://cran.us.r-project.org/src/contrib/Archive/tmap/tmap_2.2.tar.gz
These packages have more recent versions available.
It is recommended to update all of them.
Which would you like to update?

1: All                               
2: CRAN packages only                
3: None                              
4: ps       (1.7.0  -> 1.7.1 ) [CRAN]
5: processx (3.5.3  -> 3.6.1 ) [CRAN]
6: terra    (1.5-21 -> 1.5-34) [CRAN]
7: proxy    (0.4-26 -> 0.4-27) [CRAN]
8: DBI      (1.1.2  -> 1.1.3 ) [CRAN]
9: classInt (0.4-3  -> 0.4-7 ) [CRAN]

Enter one or more numbers, or an empty line to skip updates: 

I pressed enter to skip the updates the same error messages pops up again: needing version >3.5 of geos instead of 3.4.2.
Question: what is the best way to install tmap on my server with its limitations (not being able to change the underlying libraries)?