virtualenv_install packages spacy killed in RStudio Cloud

#1

I tried using virtualenv_install() to install the spaCy package. But it stops with the error message "Killed".

Any advice how to fix this? Thanks.

0 Likes

#2

At a guess you are exceeding the current memory limit of 1 GB. I am not certain why installation of lots of Python packages would cause that.

You could try installing some of those packages individually and see if that gets you past the error.

0 Likes

#3

Hello thanks for the reply, I already tried to install those packages individually, but still I get the same error.

0 Likes

#4

It is definitely running out of memory installing just spacy.

After the initial failure, I was able to work around this by going to the Terminal, activating the reticulate virtualenv, and installing spacy from the source wheel:

$ . r-reticulate/bin/activate
$ pip install --verbose spacy --no-cache-dir --no-binary=:all:
1 Like

#5

Thank you. It works now....

0 Likes

closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

0 Likes