what do I do when psych package won't install

I have been trying to install the 'psych' package in R studio. I have tried downloading from forge, directly from github using devtools, unistalling and then reinstalling the package. I have no idea whats wrong, this package worked before a few months ago, I am not sure what I have done.

Installing package into ‘/Users/alan/Library/R/3.5/library’
(as ‘lib’ is unspecified)
trying URL 'http://cran.rstudio.com/src/contrib/psych_1.8.10.tar.gz'
Content type 'application/x-gzip' length 3523748 bytes (3.4 MB)
downloaded 3.4 MB

* installing *source* package ‘psych’ ...
** package ‘psych’ successfully unpacked and MD5 sums checked
** R
** data
*** moving datasets to lazyload DB
** inst
** byte-compile and prepare package for lazy loading
Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared object '/anaconda3/lib/R/library/nlme/libs/nlme.so':
  dlopen(/anaconda3/lib/R/library/nlme/libs/nlme.so, 6): Symbol not found: _libintl_dgettext
  Referenced from: /anaconda3/lib/R/library/nlme/libs/nlme.so
  Expected in: /anaconda3/lib/R/lib/libR.dylib
 in /anaconda3/lib/R/library/nlme/libs/nlme.so
ERROR: lazy loading failed for package ‘psych’
* removing ‘/Users/alan/Library/R/3.5/library/psych’
Warning in install.packages :
  installation of package ‘psych’ had non-zero exit status

The downloaded source packages are in

I really like Anaconda for Python, but I see lots of peep with issues like yours trying to compile from source code that don't happen when you use the CRAN and RStudio binaries and do regular console install.packages().

In this case, however, there may be a fix for the missing .so

See https://goo.gl/MG8LKj

Thanks for your help but that also did not work and now libraries that were working previous will not work either.

I guess I will uninstall anaconda and R and try again outside of anaconda

See this post: https://goo.gl/SJUpYG on a similar experience

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.