"What They Forgot to Teach You ..." system setup for rstudio::conf 2019

workshop
rstudio::conf

#1

This post describes pre-workshop setup necessary for the workshop:

What They Forgot to Teach You About R
at rstudio::conf 2019
Tuesday January 15 & Wednesday January 16

It's all about Git + GitHub + RStudio (the pre-workshop setup, that is).

This truly requires your attention before the morning of Tuesday January 15. We want to show you how to use Git/GitHub in your life as an R-using data analyst, which means we can't afford to get bogged down in a hot mess of Git installation issues. Let's try to work through them beforehand.

Do what's listed here: https://happygitwithr.com/workshops.html#pre-workshop-set-up

This is the thread to use if you need some help.

If you wonder why I've chosen to include Git/GitHub in this workshop, you might want to read Excuse me, do you have a moment to talk about version control?.

Go forth and install Git! :boom:


#2

I've got nearly everything done, but as I try to connect to github, linux type commands aren't working (ls, which, etc.). It appears there was another post on the github about this, but the solution there didn't work.

image

Any suggestions?

-Greg


#3

How did you get into the terminal above? I'm guessing you're on Windows, so it would also be good to use the methods here to find our exactly which sort of shell you are in:

If there's any doubt, make sure to restart RStudio after installing Git for Windows (assuming that's the OS we're talking about). Also make sure you're using a current version of RStudio (I generally run the Preview version).


#4

You are correct. I am using windows. I updated yesterday, so I'm on RStudio version 1.1.463 and R 3.5.2.

The terminal in the previous picture was from the terminal in RStudio, which I'm pretty sure is a GitBash Terminal. I posted a larger picture below with more details. I am having the same issues as this, but the options when installing Git for Windows have since changed, though I did pick the option you called out in the instructions when setting the path environment options. I can run commands from the separate GitBash terminal, but not from the RStudio terminal.


#5

I also a notice a strange behaviour with git bash working on windows but not in RStudio terminal.

I think you should also configure your PATH to get access to bash tool in terminal. What have you in your PATH ? echo $PATH in terminal should help.

I think you need to have the bin directory of GIT installed folder,to make it work. At least, that is where ls and other tools are on my setup.


#6

I was actually able to get everything working today.

I uninstalled everything. upgraded to the preview version of r studio and re-installed git for windows, and it all seemed to work perfectly.


#7

Great, glad to hear the second time's the charm!