Why is rstudio login page appearing at localhost:8787?

Earlier today I have been running rstudio docker containers. After struggling to login with the password I set while running the images, I tried stopping the containers in order to rerun a new one with the same name.

No running containers:

doug:~$ docker container ls
CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS              PORTS               NAMES

However, if I navigate to localhost:8787 I am redirected to the sign in page:

I discovered this because the password that I previously used to login to the docker container was not working. I was and still am very confused. If rstudio on localhost is coming from some other process, then it would make partial sense that my regular password that I use with the container was not working.

I'm on a laptop running on Linux Ubuntu.

I have tried several different browsers and clearing cookies and storage. This login page still appears.

What could be causing this?

Turns out I was running rstudio server on my ubuntu device. I must have installed it by accident while trying to install rstudio app. Or when I was messing around with docker. Anyway, solution was to purge rstudio server https://askubuntu.com/questions/1279955/how-to-stop-app-rstudio-loading-on-localhost8787/1280259#1280259

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.