Windows 10 Enterprise doesn't run the Rstudio

Hello World, first time asking a question here.

I am trying to help my wife install R and Rstudio.
I got the latest version of R (4.2.1) and Rstudio (2022.07.1)

When I tried to run Rstudio it says: "This app can't run on your PC"
I checked the system type and its 64-bit
The laptop is a "Samsung Galaxy Book Go" (she got it last year)

Windows edition: Windows 10 Enterprise version 21H2 installed on May 2022

Anyone knows how should we solve this problem?

Hi @CYCY - RStudio does work on Windows 10 Enterprise as I run it on my work laptop.

If I were you I would try the following to troubleshoot the issue:

  • First try uninstalling, clearing all Appdata and registry entries, restart machine and reinstalling R and Rstudio

  • try running the RStudio executable in "compatibility mode" by right clicking the exe and selecting run in compatibility mode.

  • Check the windows event logs for more insights into the application crashes / unable to start

  • if it's a company machine there could be a group policy in place that blocks running certain software. You can try starting the computer in Safe Mode and testing

  • run the system file checker as admin from CMD - sfc /scannow (DISM could also help)

  • run cleanmgr to cleanup junk files

  • create a local admin user and install using that account

There's 100 more things that could help but you need to get more information than "this app cannot run on your PC" first

Thank you! I will try these steps first