YAML Error on blogdown update

I am having a similar issue described in the question here. After updating {blogdown} from version 0.19 to the development version, I get this error when running blogdown:::serve_site():

Error: logged 1 error(s)
Error in yaml.load(readLines(con), error.label = error.label, ...) : 
  (/var/folders/k3/3r1x7stn02732jhykrywxjmh8cg07m/T//RtmpTEDEyw/file10f2010f1a203.md) Parser error: did not find expected <document start> at line 10, column 1
  1. blogdown:::serve_site()
  5. blogdown:::site_base_dir()
  6. blogdown:::load_config()
  7. blogdown:::parser(f)
  8. blogdown:::yaml_load_file(f2)
  9. yaml::yaml.load_file(...)
 10. yaml::yaml.load(readLines(con), error.label = error.label, ...)

I haven't changed any of the Rmd files in my website, only updated the {blogdown} package. I have tried to remove the post/, project/, publication/, etc. directories to narrow down where the problem is, but the problem persists, even when removing all directories.

The source code for the website is here (currently working on the update-blogdown branch).

And session info:

#> R version 4.0.2 (2020-06-22)
#> Platform: x86_64-apple-darwin17.0 (64-bit)
#> Running under: macOS Mojave 10.14.6
#> Locale: en_US.UTF-8 / en_US.UTF-8 / en_US.UTF-8 / C / en_US.UTF-8 / en_US.UTF-8
#> Package version:
#>   base64enc_0.1.3  BH_1.72.0.3      blogdown_0.21.34 bookdown_0.21.3 
#>   digest_0.6.27    evaluate_0.14    glue_1.4.2       graphics_4.0.2  
#>   grDevices_4.0.2  highr_0.8        htmltools_0.5.0  httpuv_1.5.4    
#>   jsonlite_1.7.1   knitr_1.30       later_1.1.0.1    magrittr_1.5    
#>   markdown_1.1     methods_4.0.2    mime_0.9         promises_1.1.1  
#>   R6_2.5.0         Rcpp_1.0.5       rlang_0.4.8      rmarkdown_2.5.3 
#>   servr_0.20       stats_4.0.2      stringi_1.5.3    stringr_1.4.0   
#>   tinytex_0.27     tools_4.0.2      utils_4.0.2      xfun_0.19       
#>   yaml_2.2.1      
#> Hugo version: 0.54.0

Created on 2020-11-04 by the reprex package (v0.3.0)

Any suggestions on what could be causing this error?

1 Like

I can reproduce your problem, and will look into it soon. Thanks for the report!

1 Like

From my initial investigation, this appears to be due to a bug of Hugo 0.54.0. However, your theme doesn't work with the latest version of Hugo (0.78.0; I also tested 0.76.5 and it failed, too). I'll see what I can do.

Should be fixed in the dev version of blogdown now:


You'll still see this message but it's harmless and can be ignored:

Error: logged 1 error(s)

I believe there was a bug in Hugo 0.54.0, which was fixed somehow in Hugo 0.55.0, but I didn't find the mention in the release notes of 0.55.0.


This solved it! Thank you!!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.