You can't install the software because it's not available on the software update server

Hi! I have a error in Rstudio and I wanted to see if anyone knows how to fix it.

First it comes out: "The git command requires the installation of the command line developer tools. Do you want to install them now?

When I click on install and looking for software, I get the following error: "You can't install the software because it's not available on the software update server.

I don't know how to fix this error because I have the maximum version of Rstudio and my MAC


Looks like a common problem right now, related to git. Looking into it.

I am running into the same problem! My RStudio and Mac are all running on the most updated software.

We believe that the latest version of Xcode from apple doesn't include the command line tools. Installing xcode manually might solve the problem. See Help Installing R Studio onto Macbook Pro
Let me know if that helps?


I ended up removing my current command line tools in terminal:
sudo rm -rf /Library/Developer/CommandLineTools

then I downloaded an older version of the command line tools since git was my main problem and it no longer runs on OSX 10.15.

I did this by going to and downloading Command Line Tools 11.3.1!

It works now. Not a permanent fix, but helped.


Wonderful! Thank you for trying this. Several other topics have popped up recently with the same problem; I'll point them at this topic for a short term solution until Apple releases a fixed version of XCode.


Thank you! I was banging my head against the wall for hours trying to fix this issue and this finally did it!

I'm glad it helped! My mac reminds me to update my command line tools under Software Update -- so just make sure you don't do that until they fix this bug or else you'll have to do this process all over again :slight_smile:

Hi Rebecca, I'm new to rstudio but am facing the same problem... would you mind providing a bit more of a detailed step-by-step of how to work around the issue? Would really appreciate it!

1 Like

Hey there -

Go to your finder and type in "Terminal" to open the Terminal app.
Copy and paste: sudo rm -rf /Library/Developer/CommandLineTools
push enter
*you have now manually removed your command line tools

then go to and search "Command Line Tools for Xcode 11.3.1"
Click it and then download it
*you have now manually added a command line tools set

**Note: My Macbook Pro then kept telling me to update my command lines software. I ended up updating my software to Command Line Tools for Xcode 12.2 and it still works. I would recommend trying to update your Command Line Tools if your computer settings says it's available. If not, do the steps I just mentioned and it should work :slight_smile:

1 Like

Thank you Rebecca, that worked! Really appreciate you spelling it out for me...

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.