R package Installation error

Error in eval(exprs[i], envir) : object 'confint.default' not found
Using github PAT from envvar GITHUB_PAT
Downloading GitHub repo tidyverse/tidyverse@HEAD
These packages have more recent versions available.
It is recommended to update all of them.
Which would you like to update?

1: All                            
2: CRAN packages only             
3: None                           
4: stringi (1.6.2 -> 1.7.3) [CRAN]

Enter one or more numbers, or an empty line to skip updates: 1
stringi (1.6.2 -> 1.7.3) [CRAN]
Rcpp    (NA    -> 1.0.7) [CRAN]
isoband (NA    -> 0.2.5) [CRAN]
Skipping 1 packages ahead of CRAN: data.table
Installing 3 packages: stringi, Rcpp, isoband
Installing packages into ‘/usr/lib/R/library’
(as ‘lib’ is unspecified)
trying URL 'https://cloud.r-project.org/src/contrib/stringi_1.7.3.tar.gz'
Content type 'application/x-gzip' length 7599615 bytes (7.2 MB)
==================================================
downloaded 7.2 MB

trying URL 'https://cloud.r-project.org/src/contrib/Rcpp_1.0.7.tar.gz'
Content type 'application/x-gzip' length 2941808 bytes (2.8 MB)
==================================================
downloaded 2.8 MB

trying URL 'https://cloud.r-project.org/src/contrib/isoband_0.2.5.tar.gz'
Content type 'application/x-gzip' length 1671911 bytes (1.6 MB)
==================================================
downloaded 1.6 MB

Error in eval(exprs[i], envir) : object 'confint.default' not found
Using github PAT from envvar GITHUB_PAT
Downloading GitHub repo tidyverse/tidyverse@HEAD
stringi (1.6.2 -> 1.7.3) [CRAN]
Rcpp    (NA    -> 1.0.7) [CRAN]
isoband (NA    -> 0.2.5) [CRAN]
Skipping 1 packages ahead of CRAN: data.table
Installing 3 packages: stringi, Rcpp, isoband
Installing packages into ‘/usr/lib/R/library’
(as ‘lib’ is unspecified)
trying URL 'https://cloud.r-project.org/src/contrib/stringi_1.7.3.tar.gz'
Content type 'application/x-gzip' length 7599615 bytes (7.2 MB)
==================================================
downloaded 7.2 MB

trying URL 'https://cloud.r-project.org/src/contrib/Rcpp_1.0.7.tar.gz'
Content type 'application/x-gzip' length 2941808 bytes (2.8 MB)
==================================================
downloaded 2.8 MB

trying URL 'https://cloud.r-project.org/src/contrib/isoband_0.2.5.tar.gz'
Content type 'application/x-gzip' length 1671911 bytes (1.6 MB)
==================================================
downloaded 1.6 MB

Error in eval(exprs[i], envir) : object 'confint.default' not found
Using github PAT from envvar GITHUB_PAT
Downloading GitHub repo tidyverse/tidyverse@HEAD
stringi (1.6.2 -> 1.7.3) [CRAN]
Rcpp    (NA    -> 1.0.7) [CRAN]
isoband (NA    -> 0.2.5) [CRAN]
Skipping 1 packages ahead of CRAN: data.table
Installing 3 packages: stringi, Rcpp, isoband
Installing packages into ‘/usr/lib/R/library’
(as ‘lib’ is unspecified)
...
...

Somebodytake a look? Studying Coursera Course

「customer or user complaints」but not 「staff complaints」not scammer.

Is it possible to tune it on both Local PC and Cloud☁️, how to develop R language & statistics without tune the most fundamental packages installation & packages update.

Gonna studying to get Coursera νerified ξconometrics Certificates and R&D on Advanced Algorithmic HFT prior to flight :flight_departure::airplane: to :flight_arrival: :cn:.

thats error on install.packages and update.packages on any package. via Rgui, RStudio and also RStudio.Cloud...

  • local Rgui and RStudio auto prompt an error confint.level and switch to tidyverse with endless loop and unable install any package.
  • RStudio.Cloud shows an error non 00-lock and unable install any package.

Tried traceback(install.packages(...)) and traceback(update.packages(...)) but didn't show error on which specific function or which specific line in order to correct it... Somebody shade me a light?

refered below link, reinstall r & rstudio but doen't work on my case.

Hi @englianhu!
I'm afraid I don't know know what's going on here.

Have you tried asking R-SIG-Debian@r-project.org or sharing the query on Twitter with the appropriate tags (e.g., #rstats, @Ubuntu, etc.), StackOverflow, etc.?
If you haven't done it yet, try that and remember to avoid crossposting.

I hope someone else can come up with some more pragmatic solution.
Best of luck,
V

Thanks via post Centos 'lib="/usr/local/lib64/R/library"'不可写 如何解决 make me recall the installation of RStudio Server and Shiny Server via terminal 第2.2章 : 安装R服务器中の程序包, although the error still there but at least :$ sudo su - -c "R -e \"devtools::update_packages()\"" make update and install packages working fine.


Expected solution:

There might most probably key_rsa(finger print) by Micheal as I knew from below link, will reinstall R via source package :package: without key_rsa as what I used to first installed R Version >=4 before officially updated by Micheal on CRAN.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.