0 [main] cut (17860) C:\rtools40\usr\bin\cut.exe: *** fatal error - cygheap base mismatch detected - 0x180331408/0x180316408

Since I moved to R 4.0.0 and Rtools 4.0 I get the error message in the subject line when I start a new Git bash terminal. The error message continues:

This problem is probably due to using incompatible versions of the cygwin D
LL.Search for cygwin1.dll using the Windows Start->Find/Search facility
and delete all but the most recent version. The most recent version shoul
d

reside in x:\cygwin\bin, where 'x' is the drive on which you have
installed the cygwin distribution. Rebooting is also suggested if you
are unable to find another cygwin DLL.

I only have one cygsin installation, although it is located in c:\cygwin64 rather than c:\cygwin. So far it hasn't actually stopped me from doing anything in the terminal, so maybe it doesn't matter, but it would be good to know how to fix it if anyone can help.

Thanks
David

2 Likes

No help I'm afraid, but i'm getting the same thing. Reinstalled Rtools and git for windows but no change.

There's a patch and suggested solutions here:

This is based on a few bug reports that included the same error message.

2 Likes

Never mind, I see you can fix it by using the 'Custom' option. Thanks again.

Hi @DavidB , sorry where is this "Custom" option?

I have the same issue as yourself and am not sure how to apply the fix.

Thanks!

Go to the Terminal tab in Global Options, change New terminals open with to Custom, and then put the location of bash.exe in the Custom shell window (on my system it is C:/Program Files/Git/bin/bash.exe).

2 Likes

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Same here; solution is welcome!

Thanks, that's very helpful.

Any idea when this patch will be rolled out? It's not fixed in the latest release of either 1.2 or 1.3.