500 Error: Application failed to start

I made a very basic app (only a couple deviations away from the default Shiny app) and it works fine locally but when I try to deploy to shinyapps.io, I get a 500 error. When I run options(rsconnect.http.trace=TRUE) and looked at the output, it keeps saying "Connection cache is full". I'm only loading 5 packages in (dplyr, ggplot2, tigris, shiny, and rsconnect). I'm not sure if this has to do with my RDS files (shown with their file sizes below).

Things I've already tried:

  • Deleting the app's .dct file and redeploying
  • Deleting the app from shinyapps.io and redeploying
  • Turning off package caching in the shinyapps.io settings

The very strange part of all of this is that when I do an initial deploy from scratch, it will say that the app successfully deployed but then when I get on shinyapps.io, there are no logs. Any help would be appreciated - thank you!

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.