Azure HDInsight RStudio Server Packages Not Installing

I have provisioned an Azure HDInsight cluster type ML Services (R Server), operating system Linux, version ML Services 9.3 on Spark 2.2 with Java 8 HDI 3.6.

I am able to login to Rstudio on the head node via SSH access and I ran the script

from this tutorial -

located here:

to install H2o related packages unto the head and worker nodes.

When I run the library(sparklyr) and library(dplyr) it works fine, however Rstudio does not find the h2o package and when I try to install the h2o package it fails because RCurl is not installed. Then when I try to install RCurl I get the following error "Error : package 'bitops' required by 'RCurl' could not be found". When I install bitops it successfully installs but RCurl does not seem to be finding the bitops package within the default install directory temp folder on the HDInsight head node VM's harddrive.

My question is, how do I get the Rstudio Server to recognize where packages are installed on my HDInsight head node? I am using the default install directory when installing each package but the subsequent packages do not recognize dependent packages are installed.


I figured it out, but in case anyone else has this issue. I solved it by installing the packages on every node using the method found here: using the action script to install packages.

I was originally only installing the packages on the head and worker nodes. Once I installed the packages on all nodes I had no issues.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.