Blank, unresponsive terminal pane, no cursor

Hi there,

I am unable to open the Terminal in RStudio (Windows, Desktop).

At first it would open, but no cursor, and would not accept inputs.

There is a Github issue listed here where it recommends installing the latest Daily Build version.

I did so, installing Version 1.3.745, but now if I try to open a terminal in RStudio I get:

image

Under Terminal diagnostics I receive this:

Global Terminal Information
---------------------------
Loaded TerminalSessions: 1
Handle: '1DF733A9' Caption: 'Terminal 1'

Terminal List Count: 1
Handle: '1DF733A9' Caption: 'Terminal 1' Session Created: true

Current Terminal Session Information
------------------------------------
Caption:     'Terminal 1'
Title:       ''
Cols x Rows  '117 x 12'
Shell:       'Git Bash'
Handle:      '1DF733A9'
Sequence:    '1'
Restarted:   'true
Busy:        'true'
Exit Code:   'null'
Full screen: 'client=false/server=false'
Zombie:      'false'
Track Env    'false'
Local-echo:  'false'
Working Dir: 'Default'
Interactive: 'Always'
WebSockets:  'true'

Current Terminal Emulator Settings
------------------------------------
bellStyle: sound
cursorStyle: block
fontFamily: "Lucida Console", monospace
fontWeight: normal
fontWeightBold: bold
rendererType: canvas
allowTransparency: false
cancelEvents: false
convertEol: false
cursorBlink: true
disableStdin: false
drawBoldTextInBrightColors: true
macOptionClickForcesSelection: false
macOptionIsMeta: false
rightClickSelectsWord: false
screenReaderMode: false
windowsMode: true
fontSize: 19
letterSpacing: 0
lineHeight: 1
tabStopWidth: 8
scrollback: 1000

System Information
------------------
Desktop:    'true'
Remote:     'false'
Platform:   'Windows'

Connection Information
----------------------
2020/1/16 18:58:23: Connect WebSocket: 'ws://127.0.0.1:4296/terminal/1DF733A9/'
2020/1/16 18:58:23: WebSocket connected
2020/1/16 18:58:24: Disconnected
2020/1/16 18:58:24: WebSocket closed

Local-echo Match Failures
-------------------------
<Not applicable>

It seems this issue has arisen for other users over the past 2 years or so, but I can't find a concrete fix anywhere.

Any advice?

Sorry to hear you are having trouble with this.

As a troubleshooting experiment to help narrow down the problem, can you try switching to Command Prompt instead of Git Bash, and see if you can start a terminal that way?

Tools / Global Options / Terminal, "New terminals open with:" Command Prompt

Then try and open a new terminal in RStudio and share the results.

Hi Gary,

Hmm yes that is something I tried earlier; doing so now results in the same error:
image

Hitting OK on that dialog and then hitting Enter at the Terminal results in this:
image