Blogdown do not react to custom themes and fonts

I was following @apreshill's blogdown settings to customize fonts and themes of my blogdown site, and created the data/fonts, data/themes folder and the corresponding toml files under the root directory. I then changed the font and theme entry in params.toml, but the rendered site did not change. Even when I modified the theme and fonts in params.toml to some build-in settings (e.x., ocean for theme and mr_robot for fonts) of the academic theme, the site is still the same as https://qiushi.rbind.io

Help is really appreciated

Hi there! Thanks for providing so much information, although I'm not able to replicate the error. I downloaded your repo files, opened the R project file, using the blogdown "serve site" add-in, and changed the font and theme in the params.toml file. All colors and fonts updated locally as I made those changes, so everything is wired up correctly. So maybe two more questions:

  1. Are you serving site locally and not seeing changes happen when you change font/theme settings in params.toml? If so try deleting your public folder then serving site again.

  2. Or do you possibly mean that you aren't seeing the theme update on your deployed site? If not, I would check your Netlify deploy logs to see what is happening when you change fonts/themes, and commit and push those changes to the params.toml file to GitHub.

Thanks! I will look into that

After deleting the public folder, I served the site locally, and it still didn't change :sob: Then I created a new blogdown project containing the default hugo-academic settings, and I could not manage to switch between built-in themes and fonts, the served site still looked the same as https://academic-demo.netlify.com/ (other changes such as customizing the navbar worked well). It seems all my blogdown projects sort of ignore params.toml :thinking:

OK just to be 100% sure here, are you editing the file:

config/_default/params.toml

That is, you are not editing other params.toml files located in subfolders under theme/hugo-academic/, right?

1 Like

Sure, config/_default/params.toml

Update: The locally served site still won't work, but I figured that if netlify could deploy directly from Github then everything is rendered fine ... I used to upload the locally rendered public folder manually. Anyway thanks a lot Allison, your blogdown tutorial and posts surely helped me alot :slight_smile: