bookdown install failed

In attempting to install bookdown, RStudio (and plain R) fails with

Installing package into ‘C:/Users/David Stevens/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
also installing the dependency ‘tinytex’

There is a binary version available but the source version is later:
binary source needs_compilation
bookdown 0.15 0.16 FALSE

trying URL ''
Content type 'application/zip' length 100422 bytes (98 KB)
downloaded 98 KB

package ‘tinytex’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
C:\Users\David Stevens\AppData\Local\Temp\RtmpqoRa02\downloaded_packages
installing the source package ‘bookdown’

trying URL ''
Content type 'application/x-gzip' length 765525 bytes (747 KB)
downloaded 747 KB

Warning: invalid package 'C:\Users\David'
Warning: invalid package 'Stevens\AppData\Local\Temp\RtmpqoRa02/downloaded_packages/bookdown_0.16.tar.gz'
Error: ERROR: no packages specified
Warning in install.packages :
installation of package ‘bookdown’ had non-zero exit status

The downloaded source packages are in
‘C:\Users\David Stevens\AppData\Local\Temp\RtmpqoRa02\downloaded_packages’

I suspect it has to do with the blank space between my first and last names for the library folder but I don't know how to test it. Any help is appreciated.

I think you are right, to test if this is true, try installing to the system level library, you would have to run RStudio as administrator for this to work.

# I'm assuming you have the latest R version installed, if not change the path accordingly.
install.packages("bookdown", lib = "C:\\Program Files\\R\\R-3.6.1\\library")

Thanks Andre - I tried this and get the same error. Not sure where to go next.

Could you post the error message you are getting? I'm sure it has to be at least a little different from the previous one.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.