Cannot install Car package, I get the error ; Loading required package: carData Warning message: package ‘car’ was built under R version 3.5.1

rstudio
package

#1

Loading required package: carData
Warning message:
package ‘car’ was built under R version 3.5.1


#2

This is just a warning, and doesn't necessarily indicate that there's a problem. It occurs when the package you're installing was built under an R version different from the one you're using, but is often fine.

Are the functions you'd expect to be there there?

Also, note that the package you're attaching there/for which the warning is thrown is carData and not car itself.


#3

Hello Mara, it is a warning but I cannot use any of its functions, example plotmatrix(),


#4

I don't think this is a function inside of car. There's scatterplotMatrix().
See car reference manual here: https://cran.r-project.org/web/packages/car/car.pdf


#5

Error in scatterplotmatrix(~mpg + disp + drat + wt | cyl, data = mtcars, :
could not find function "scatterplotmatrix"


#6

Thanks, it was a typo !, it is working now