Cannot load doBy package

With doBy package successfully installed, library(doBy) cannot load doBy
the error message is as follows.

library(doBy)
Error: package or namespace load failed for ‘doBy’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
네임스페이스 ‘vctrs’ 0.2.4는 이미 로드되었으나 >= 0.3.0가 필요합니다
(Transalation: Namespace 'vctrs' 0.2.4 is already loaded but >= 0.3.0 is required)

My R version is 4.0.0. Does it matter?
I tried to update to 4.0.2. I updated with "updateR()" and the result was successful, but R version still remaining as 4.0.0.

It would be great if you can give me an answer.

Just

update.packages('vtrts')

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Thank you for your tip, but it doesn't work.
The error message hasn't changed.

After update did you then

library(vtrts)

Its a typo, vctrs rather than vtrts.
I think the main educational point though, is that the original error message was explicit about what the problem was, and the translation service this forum provided was simply reading the message and explaining that the wrong version of a package being loaded can be addressed by the user manually installing the latest version of a package in question.

It seems that my R has a version problem.
if I update R to 4.0.2, will these issues resolved?
Thank you.

install.packages("vtrts")
Warning in install.packages :
package ‘vtrts’ is not available (for R version 4.0.2)
update.packages("vtrts") <= no response
library(vtrts)
Error in library(vtrts) : ‘vtrts’이라고 불리는 패키지가 없습니다 <= translation No package called 'vtrts'

signifies that a later version of the vctrs package than the one installed is required.

package ‘vtrts’ is not available (for R version 4.0.2)

indicates that R 4.0.2 is already installed. (You can verify this with sessionInfo()). However, the difference between the two releases should not make a difference for your purposes.

The problem is due to my typo: try

install.packages("vctrs")